summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bfbe5a8..e6f91a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=7zip
pkgver=24.09
-pkgrel=2
+pkgrel=3
pkgdesc="File archiver for extremely high compression"
arch=('x86_64')
url="https://www.7-zip.org"
@@ -15,10 +15,6 @@ replaces=('p7zip')
source=(https://7-zip.org/a/7z${pkgver//./}-src.tar.xz)
sha256sums=('49c05169f49572c1128453579af1632a952409ced028259381dac30726b6133a')
-prepare() {
- sed -i '/^LFLAGS_ALL = /s/$(LFLAGS_STRIP)//' CPP/7zip/7zip_gcc.mak
-}
-
build() {
local _platform_flags=()
@@ -36,6 +32,7 @@ build() {
for component in Bundles/{Alone,Alone7z,Format7zF,SFXCon} UI/Console; do
make -C CPP/7zip/$component -f ../../cmpl_gcc.mak "${_platform_flags[@]}" \
+ LFLAGS_STRIP= \
CC="cc $CPPFLAGS $CFLAGS $LDFLAGS" \
CXX="g++ $CPPFLAGS $CXXFLAGS $LDFLAGS"
done