summaryrefslogtreecommitdiff
path: root/pkgbuilds/xcross-git/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pkgbuilds/xcross-git/PKGBUILD')
-rw-r--r--pkgbuilds/xcross-git/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/pkgbuilds/xcross-git/PKGBUILD b/pkgbuilds/xcross-git/PKGBUILD
new file mode 100644
index 0000000..b08bce5
--- /dev/null
+++ b/pkgbuilds/xcross-git/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Xiao Pan <gky44px1999@gmail.com>
+
+pkgname=xcross-git
+pkgver=r11.57ac97d
+pkgrel=2
+pkgdesc='X11 draw a cross at cursor across screen '
+arch=('x86_64')
+url='https://gitlab.com/flyxyz123/xcross'
+license=('GPL3')
+depends=('libx11')
+makedepends=('git')
+provides=('xcross')
+conflicts=('xcross')
+source=("git+$url.git")
+b2sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ make
+}
+
+package()
+{
+ cd "$srcdir/${pkgname%-git}"
+ make PREFIX=/usr DESTDIR="$pkgdir/" install
+}