diff options
author | nl6720 <nl6720@archlinux.org> | 2024-12-28 16:19:51 +0200 |
---|---|---|
committer | nl6720 <nl6720@archlinux.org> | 2024-12-28 16:19:51 +0200 |
commit | edea47939b44fabe804cddfca5a51ea3058e3cec (patch) | |
tree | 8e82265b265ea1b2f4e71aa18c8a797dd0d8a3dc /PKGBUILD | |
parent | 78060211cd30c74b923c455af0434a4e38875b56 (diff) |
Use printf to improve readability
Using `printf` with a single-quoted string avoids the need to escape double
quotes.
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 3 |
1 files changed, 1 insertions, 2 deletions
@@ -48,8 +48,7 @@ package() { mkdir -p "$pkgdir/usr/bin" for _prog in 7za 7zr 7z; do - echo -e "#!/bin/sh\nexec /usr/lib/7zip/$_prog \"\$@\"" >"$pkgdir/usr/bin/$_prog" - chmod +x "$pkgdir/usr/bin/$_prog" + printf '#!/bin/sh\nexec /usr/lib/7zip/%s "$@"\n' "$_prog" | install -m755 /dev/stdin "$pkgdir/usr/bin/$_prog" done install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" DOC/{,unRar}License.txt |