summaryrefslogtreecommitdiff
path: root/any/fsh-git/PKGBUILD
diff options
context:
space:
mode:
authorXiao Pan <gky44px1999@gmail.com>2024-05-28 00:57:44 -0700
committerXiao Pan <gky44px1999@gmail.com>2024-05-28 00:57:44 -0700
commit7e22ffb5ba35b7fa1699feddd70f4e7c381e0318 (patch)
tree0a897f3230013d5f191be2e405a26a4446f11faf /any/fsh-git/PKGBUILD
parentc47a29338caaffd202ad8d1223f663bd07846155 (diff)
fsh added dynotify C program which needs build now
Diffstat (limited to 'any/fsh-git/PKGBUILD')
-rw-r--r--any/fsh-git/PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/any/fsh-git/PKGBUILD b/any/fsh-git/PKGBUILD
index ad4bf34..4412fd4 100644
--- a/any/fsh-git/PKGBUILD
+++ b/any/fsh-git/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=fsh-git
pkgver=r3.368c1b9
-pkgrel=1
+pkgrel=2
pkgdesc='My shell scripts utilities'
arch=('any')
url='https://git.flylightning.xyz/fsh'
@@ -19,6 +19,11 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ make
+}
+
package() {
cd "$srcdir/${pkgname%-git}"
make PREFIX=/usr DESTDIR="$pkgdir/" install