summaryrefslogtreecommitdiff
path: root/any/fsh-git/PKGBUILD
diff options
context:
space:
mode:
authorXiao Pan <gky44px1999@gmail.com>2024-01-09 06:14:26 -0800
committerXiao Pan <gky44px1999@gmail.com>2024-01-09 06:14:26 -0800
commitc12d4f6dfed977ba09a13d91e1b4f786601d7e75 (patch)
tree7b2872c33f1da569a78b68eaaa8714f92c6c1371 /any/fsh-git/PKGBUILD
parentb284d75ff70139672727f6ead90587ed6aa65630 (diff)
add fsh-git
Diffstat (limited to 'any/fsh-git/PKGBUILD')
-rw-r--r--any/fsh-git/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/any/fsh-git/PKGBUILD b/any/fsh-git/PKGBUILD
new file mode 100644
index 0000000..05a41a7
--- /dev/null
+++ b/any/fsh-git/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Xiao Pan <gky44px1999@gmail.com>
+
+pkgname=fsh-git
+pkgver=r3.368c1b9
+pkgrel=1
+pkgdesc='My shell scripts utilities'
+arch=('any')
+url='https://git.flylightning.xyz/fsh'
+license=('GPL-3.0-or-later')
+depends=('sh')
+makedepends=('git')
+provides=('fsh')
+conflicts=('fsh')
+source=("git+$url")
+b2sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make PREFIX=/usr DESTDIR="$pkgdir/" install
+}