summaryrefslogtreecommitdiff
path: root/any/pass-otp_fix-hotp-counter-git/PKGBUILD
diff options
context:
space:
mode:
authorXiao Pan <gky44px1999@gmail.com>2023-11-01 01:30:25 -0700
committerXiao Pan <gky44px1999@gmail.com>2023-11-01 01:30:25 -0700
commit9c7db59a68a924dab2da59b1da9acd30662e80bf (patch)
treed1671924d74d0e0d971afc7175a9029b0c1a9698 /any/pass-otp_fix-hotp-counter-git/PKGBUILD
parent2df9b72017de59fac56e01b55422ad8b450c1e12 (diff)
pass-otp fork by jorti addressed bug of hotp counter, more see https://github.com/tadfisher/pass-otp/pull/172
Diffstat (limited to 'any/pass-otp_fix-hotp-counter-git/PKGBUILD')
-rw-r--r--any/pass-otp_fix-hotp-counter-git/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/any/pass-otp_fix-hotp-counter-git/PKGBUILD b/any/pass-otp_fix-hotp-counter-git/PKGBUILD
new file mode 100644
index 0000000..0c2897c
--- /dev/null
+++ b/any/pass-otp_fix-hotp-counter-git/PKGBUILD
@@ -0,0 +1,30 @@
+# Contibutor: Morten Linderud <foxboron@archlinux.org>
+# Contibutor: Alexandre Pujol <alexandre@pujol.io>
+
+pkgname='pass-otp_fix-hotp-counter-git'
+pkgver=r136.0447ae4
+pkgrel=2
+# https://github.com/tadfisher/pass-otp/pull/172
+pkgdesc='A pass extension for managing one-time-password (OTP) tokens. With hotp counter fix.'
+arch=('any')
+url='https://github.com/jorti/pass-otp'
+license=('GPL3')
+depends=('pass'
+ 'oath-toolkit'
+ 'qrencode')
+makedepends=('git')
+optdepends=('perl-pass-otp')
+provides=('pass-otp')
+conflicts=('pass-otp')
+source=("git+$url.git#branch=fix-hotp-counter")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%_fix-hotp-counter-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%_fix-hotp-counter-git}"
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+}